Scalix AD GUI Extension not showing up on Server2008_x64

Discuss installation of Scalix software

Moderators: ScalixSupport, admin


Scalix AD GUI Extension not showing up on Server2008_x64

Postby ChrisR » Tue Dec 09, 2008 12:41 pm

I tried to setup Scalix AD Integration on a recently installed Server2008_x64_sp1_german.
First installed shema extensions with Scalix AD Schema Extensions.msi and scalixforestprep.exe --install
"Update successful" showed up so everything seems to be ok.
Then i ran Scalix AD GUI Extensions.msi to install the GUI.
Again no error-messages showed up.
But when i try to add the Scalix Management snap-in into the mmc via the add/remove snap-in feature, there is no Scalix Management entry in the list.
Also when i add new users, there are no Scalix-related screens to fill in mailnode,email address ect. and there arent`t any Scalix-related tabs in the properties of a created user.
So has anyone got this Windows-part of the AD Integration up and running on a Server2008_x64?
Please help

Posts: 239
Joined: Thu Jun 19, 2008 10:03 am

Postby LeslieW » Fri Dec 12, 2008 5:22 pm

I don't know of anyone that has tried installing the schema and GUI extensions on Windows 2008 yet.

When you installed the extensions, were you using an account that is a *schema* administrator (not domain admin)?

Can you see the new Scalix attributes in AD if you use a tool like ADSI to browse the AD?


Postby ChrisR » Sat Dec 13, 2008 5:52 am

The shema extension is not the problem. I can see the attributes with the ADSI-Editor an can populate them. It seems to be that the actual release of the gui-extensions will not work on x64 systems. I installed two servers for testing, one server2008_x64 and one server2008_x86. On the x86 system everything works like expected. On the x64 system the same problems occured as on the server in my first posting.
I hope this bug will be fixed soon, because it makes not much fun to populate the attributes of users with the ADSI-Editor.

Posts: 309
Joined: Tue Jan 15, 2008 1:54 pm

Re: Scalix AD GUI Extension not showing up on Server2008_x64

Postby ltward » Tue Mar 30, 2010 1:37 pm

Wish I could take credit for this but I cannot.

Once the extensions are installed, you will have some new files in c:\program files\Scalix\Administration. One of these is ScalixForestPrep.exe which you ran as part of installing the extensions.

One of them is AdminMMC.dll.
regsvr32 C:\Program Files\Scalix\Administration\AdminMMC.dll

Start -> Run -> MMC

Now you can see the Scalix Mgt Console in the list of available snap-ins.

Return to “Installation”

Who is online

Users browsing this forum: No registered users and 3 guests