Page 1 of 1

Can't add more domains/unable to relay

Posted: Mon Feb 17, 2020 11:03 pm
by jbru
I'm using Scalix for many years, but somehow I can't add more domains on my new server. I can add them (at sessings=>administration=>add domain), but all domains I add are unable to relay. When I remove an old domain and add a new one it works, but when I then add another one it doesn't work.

It somehow looks like there's a limit on the domains(?) Does anybody know about a limit or how to solve this problem?

FYI: I was on Scalix 12.6 but just installed 12.8 and the problem still exists.

I just tested something: When I change a existing domain e.g. to e.g. and test the relay via a telnet session it doesn't relay for but the weird thing is it still accepts relay for
So it looks like settings are saved (I still see changes I made when I log out of SAC and back in again) but somehow they aren't applied...any ideas?

Re: Can't add more domains/unable to relay

Posted: Wed Feb 19, 2020 11:34 am
by jbru
No one an idea? Can I somehow scan the server on faults? I already used omscan -Aafx but the problem still exists :(

Re: Can't add more domains/unable to relay

Posted: Tue Mar 10, 2020 9:15 am
by jbru
Still no one who can help me. I really need a new domain on the server :( :cry:

I tried everything. Also:

omcheck -s -d >

It gave me some rights errors, so I fixed it with:
sh ./

But it didn't fix my problem. I still can add domains via SAC, but although they're saved, the don't work.

Does anybody know where local/accepted domains are saved? Is this in a file or in a database? Can I somehow fix the file or database with the local/accepted domains? Or can I add a domain from the command line? Maybe that will work?

Please somebody...I'm pulling my hair out..just don't know what's going wrong... :shock:

Re: Can't add more domains/unable to relay

Posted: Tue Mar 10, 2020 9:32 am
by jbru
And a new update. If I change an existing domain e.g. to it doesn't accept mail for, but still does for
Somehow SAC shows the new/changed domain name, but the server itself isn't accepting/using the new domainname but still the old one. So it looks like a communication error in SAC?

Can anybody tell me if I can add domains from the commandline so I can test if that works???

Re: Can't add more domains/unable to relay

Posted: Sat Mar 21, 2020 4:21 pm
by pinnks
Not sure I have an answer but it seems it may be just the two of us still using these forums :?

It's a while since I last update the server and added domains but I used to do it using the install programme, if necessary running it a second time to add the additional domain. Never tried from SAC or command line.

It would be good if there were others still looking in on these boards occasionally...

Re: Can't add more domains/unable to relay

Posted: Sun Mar 22, 2020 7:27 am
by jbru
LOL, yeah I guess we're the two who hold this forum alive :lol:
Thanks for your reaction!

You say you use the installer to add more domains...but how do you do it? I can choose from 3 options:
[1] Install/Upgrade one or more Scalix components (custom)
[2] Reconfigure Scalix components
[3] Uninstall Scalix components

I guess I have to choose option 2 (reconfigure) but then again I get 8 options:
[1] Scalix DB
(version 12.8.0-15983)
[2] Scalix Tomcat
(version 9.0.24-57)
[3] Scalix Messaging Services
[4] Scalix Management Agent
[5] Scalix Web Access
[6] Scalix Management Services
[7] Scalix Search and Index Service
[8] Scalix ActiveSync

But....which one do I have to choose to add domains? And I also notice all versions are, except Scalix Tomcat. It shows version 9.0.24-57. Is this correct?

Stay safe and healthy!

P.S. I found out /var/opt/scalix/mr/caa/scalix.res/config/ holds all domain names I entered in SAC...but somehow it's not connected to the relaying domains..only to SAC. I think somehow this file has to pass this info to an other file/or update the database and that this isn't working(?)

Re: Can't add more domains/unable to relay

Posted: Sun Mar 22, 2020 1:08 pm
by pinnks

I think you would need to uninstall (keeping the various options it asks about - database of mail etc - and then re-install, so option 3 and then option 1. BUT as the domains are in the relevant file (I could not recall where they were saved in my last reply) that may not change anything.

I have 5 domains and also use the relaying function via my ISP as I run on a dynamic IP addy. All I have ever done is install, adding the domains at that time and set-up SMART_HOST to point at my ISP in /etc/mail/

This is a hobby and I am not a system admin, so I have to start from scratch each time I re-build or update the server. I have a document of personal instructions but your issue isn't specifically mentioned in that.

Re: Can't add more domains/unable to relay

Posted: Fri Apr 03, 2020 11:57 am
by jbru
I just tried, but reconfigure and add the domain during reconfigure within scalix-installer doesn't work.

Do you (or anyone) have any more ideas?

Re: Can't add more domains/unable to relay

Posted: Sun Apr 05, 2020 5:09 am
by jbru
I suddenly got it working. I checked a lot of files on the system and somehow I made a change in a file which was the correct one! (sadly I can't remember which it is :cry: )

But pinnks I want to thank you for your suggestions and helping me think! :wink:

Re: Can't add more domains/unable to relay

Posted: Fri Apr 10, 2020 10:09 am
by pinnks
Great news. The annoying thing when you're not sure how you fixed something as it is sure to break again somewhen but a small price to pay